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Preface

What is SBook?
SBook is Simson Garfinkel’s Address Book.  As a reporter, Simson seemed to be spe
his life talking on the phone and sending mail.  He had a desperate need for a fast, 
address book application that dialed the phone, kept track of whom he called, and m
easy to take and keep notes.  So he wrote SBook.

• SBook searches quickly for the person you want to contact,

• sends email and dials the phone,

• prints envelopes, mailing labels, and address books,

• and logs everything you do.

But SBook isn’t just an address book with a lot of nice features.  You can think of SB
as a smart address book because:

• SBook can recognize names, addresses, and phone numbers,  

• knows how to dial your phone, using the dialing rules in your local calling are

• and knows the difference between people and companies by looking at the n

You don’t have to type your address book entries in a rigid form.  Instead, you can
them in a natural way, including as much extra information and comments as you
SBook uses artificial intelligence technology to make sense of the information you 
into it, so that it can handle that information much as a person would.  

You can even use SBook as a general-purpose free-form database to store any text that you
can organize by name or title.  For example, you could store your favorite recipes 
SBook file.  The only things you can't store with SBook are multimedia objects contai
sounds, pictures, or other files.
SBook: Simson Garfinkel’s Address Book v
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How to use this manual
First, you’ll need to install SBook on your system.  Read ‘‘Installing SBook’’ in Appendix
B: Installing and Licensing SBook to find out how to do this.  When you have installed a
licensed your copy of SBook, read Chapter 1, Getting Started with SBook, for an overview
of what SBook does and how to use it.

You may want to have an open SBook file to play with while you read Chapter 1. 
recommend the “developers.sbook” file included in the SBook distribution; this is the
we use in most of our examples throughout the manual.  It contains a list of all the d
opers listed in the NeXT Software and Peripherals Catalog for Winter 1992.

You may also wish to look at the “congress.sbook” file and the “recipes.sbook” files, 
included in the distribution, which show how you can use SBook to organize more in
mation than just addresses and phone numbers.

What you should know

We assume that you are familiar with the standard NeXT user interface concepts, s
using the mouse (clicking, dragging, and double-clicking), using windows, menus, s
bars, standard panels such as the Font, Colors, Open, and Save panels, and using 
applications such as Edit and Mail.

If you are new to the NeXT and are unfamiliar with these concepts, we recommend tha
refer to two of the manuals that were included with your NeXT computer: NeXT Setup and
Tutorials and Next User’s Reference.

Conventions we use

We use boldface for menu choices, buttons or other objects that you click on, or m
equivalents like command-b.

We use italics for the first time something is defined, and for emphasis.

We use quotes for file and directory names (like “~/Library/Information.sbook”).

We use case when we specify menu equivalents; that is, we use command-n and
command-N rather than command-n and command-shift-n.

We use two formats for specifying the use of menus:

• “Go to the Info  menu and choose Preferences”

• “Choose Info>Preferences”

Both of these put the first menu choice first, which we hope you will find more natural 
the standard NeXT format, “Select Preferences from the Info  menu.”
vi SBook: Simson Garfinkel’s Address Book
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What’s in the manual

Chapter 1, Getting Started with SBook gives an overview of what SBook is and what it ca
do for you.  You’ll probably want to read this first.

Chapter 2, Fine-Tuning Your SBook Files explains how to make your SBook files suit yo
and your data perfectly.

Chapter 3, Dialing the Phone with SBook explains how to set up and use SBook for dialin
the phone.

Chapter 4, Importing and Exporting explains how to convert files into and out of SBook
file format.

Chapter 5, Making Reports with SBook explains how to use SBook to make bulk ema
mailings and print address books and mailing labels.

Chapter 6, Logging what you do with SBook explains how to use SBook’s logging facilitie
to keep records of your letters and telephone calls.

Appendix A: SBook’s Menus and Menu Commands gives a complete, systematic overview
of SBook’s menus and windows and what they do.

Appendix B: Installing and Licensing SBook explains about your license agreement a
how to set up and license this copy of SBook.
SBook: Simson Garfinkel’s Address Book vii
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Getting Started with SBook

This section covers the basics of using SBook: creating and using files, adding
changing information, making simple searches, and using icons to print envelopes, d
phone, and send email.  Unless noted, it assumes default settings.

+ Before you can use SBook, it must be installed.  See “Installing SBook
Appendix B: Installing and Licensing SBook for more information.

SBook entries
An SBook file consists of some number of entries.  Each entry has a name.  When you u
SBook as an address book, each entry represents a person you know.  The name of t
is the person's name, and the entry itself contains the person's address and phone n

SBook automatically places a small icon beside each postal address, email address,
phone number in a displayed entry.  You can click on these icons to have SBook pe
services for you:

 You can click on an envelope icon to print an envelope or mailing label.

 Or click on an email icon to send email.

 Or click on a phone icon to dial a phone number.

Some entries are short...

...while others may contain much more.
SBook: Simson Garfinkel’s Address Book 1
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The SBook window has several parts:

At the top of the window is the search field.  You can type in this field to search throug
the names in the file.  

The pop-up menu just below the search field, on the right, allows you to specify the search
method.

The gray numbers on the left are in the message field.  At the moment, the message fiel
displays how many names were found.  Nothing is typed in the search field right no
all of the names in the file match the search request. 

The matrix contains a scrollable list of names that match what is typed in the search 
Generally, the names in the matrix appear in alphabetical order.

When a name in the matrix is selected with the mouse, it is highlighted and its asso
entry is displayed in the display below.

search field

matrix

display

message field

search method

pop-up

+ Several names can be selected
and displayed at one time, by
dragging or using shift-click.
2 SBook: Simson Garfinkel’s Address Book
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SBook files
All files created by SBook have an extension, either “.sbook” for an ordinary SBook d
ment, or “.sbook~” for an automatically generated backup file.  SBook document files
backup files appear in your workspace with distinctive icons.  These icons are similar 
SBook application icon:

Each document file that is open within SBook appears in its own window.  The name o
file appears at the top of the window:

Creating new files

To create a new SBook file, go to the File menu and choose New, or type the shortcut,
command-N.  A new window will appear named Untitled.

+ You need to make a new entry before you can start typing information into SB
See “Adding new entries” on Page 4 for details.

Opening files

You can open a pre-existing file from within SBook by going to the File menu and choosing
Open, or typing the shortcut, command-o.  A standard Open panel will appear on th
screen.

You can also open a pre-existing SBook file by double-clicking on the file’s icon in Wo
space.  If SBook is not running, Workspace will automatically launch it for you.

+ SBook can be set up so that every time it is launched, it automatically ope
particular file or files.  See  “The Preferences panel” in Appendix A: SBook’s
Menus and Menu Commands.

application icon document icon (.sbook) backup icon (.sbook~)
SBook: Simson Garfinkel’s Address Book 3
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Closing files

You can close an SBook file by clicking on the close button of its window.  Alternativ
if the window corresponding to that file is selected, you can close it with the menu op
File>Close or Windows>Close.  Of course, quitting SBook will close all open files.

When you close a file with unsaved changes, SBook will ask you if you want to sav
file.  Click Save (the default) to save the file, No to close the file without saving it, or
Cancel if you prefer not to close the file after all.

Saving files and making backups

SBook’s File menu offers three options for saving files: Save, Save As..., and Save All.
These commands work as their counterparts do in other NeXT applications:

• File>Save As... (command-S) presents you with a standard Save panel so t
you can specify a file name and location.  Once you do this and click OK , SBook
will save the file.

• File>Save (command-s) causes SBook to save the file quietly with its curre
name and location, if that is possible.  If the file is new, you will be presented 
a Save panel (as if you had chosen File>Save As...) before SBook can save the
file.

• File>Save All will cause SBook to save all open files that need to be saved,
as if you had chosen Save for each one of them.

By default, SBook automatically makes a backup whenever a file is opened.  Once a
open, it is automatically saved after 5 minutes of inactivity.  You can change these de
in the Preferences panel (see  “The Preferences panel” in Appendix A: SBook’s Menus and
Menu Commands).

Adding new entries
Create a new entry by going to the Edit  menu and choosing New entry (command-n).  A
new entry template will appear in the display, including name, address, and com
fields.  Just type the information for the new entry directly in the display.
4 SBook: Simson Garfinkel’s Address Book
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SBook has several features that make it especially easy to type in a new entry:

• When a new entry is created, its name is selected and highlighted.  Just start 
the name of the new entry to replace the dummy name.  As you type, the nam
appear simultaneously in the display and the matrix above.

• After you type the name and hit return, SBook automatically selects and highl
“Address” on the template so that you can immediately begin typing in the add
font.

• Type as many addresses and phone numbers as you like.  Whether you are
new information or editing old information, SBook places address and ph
icons automatically, in all the right places, while you type.

Deleting entries
You can delete one or several entries from an SBook file by selecting the names 
entries that you want to delete in the matrix, and then choosing Edit>Delete entry
(command-D).  An alert panel will appear on the screen asking you to confirm that 
really want to delete the entries.

Click YES (the default) to delete the entries, and NO to cancel the request for deletion.

If there is only one entry, the
panel will refer to it by name.

If there are several entries, the panel will
warn you how many you are about to delete.
SBook: Simson Garfinkel’s Address Book 5
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Using cut, copy, and paste
SBook supplies the standard Edit  menu options Cut (command-x), Copy (command-c),
and Paste (command-v).  You can use these in two ways: copying information, or copy
whole entries.  Either way, you can copy within SBook, or between SBook and any 
NeXTSTEP application that supports copy and paste operations.

Copying information

Within SBook, copying information from one entry to another works as you would ex
it to: select the information you want to copy, choose Copy or Cut in the usual way, select
an insertion point, and choose Paste in the usual way.  The font, formatting, and icon plac
ment in the information will be preserved.

You can also copy information from an entry into any other application, or vice ve
When pasting SBook text into a Rich Text field, font and formatting will be preserved
icons will disappear.  When pasting into a plain ASCII document (or an application su
WriteNow that does not support pasting of Rich Text) only the plain text will be paste

Copying whole entries

You can also use the standard Edit  commands to copy one or more whole entries from one
SBook to another.  First, select the entries you want by clicking on their names i
matrix.  Several entries may be selected by dragging or using shift-click.

+ If any text is selected within the window, you have not selected the whole e.
You need to make sure the whole entry is selected by clicking once more o
name in the matrix.

In these two windows, only the 
word “Albuquerque” is selected.

This entry is selected in its 
entirety.
6 SBook: Simson Garfinkel’s Address Book
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Now choose Copy or Cut  in the usual way, select the target SBook file by clickin
anywhere on its window, then choose Paste in the usual way.  The entries will be paste
into the target window, and its message field will display how many entries were pas

+ Pasted entries are always added to the file as a group of new entries, whether or
not an entry or a group of entries is selected in the target window.

+ If you want to copy a large number of entries from one SBook to another, or f
another application into SBook, you probably want to use the Import  and Export
commands.  Full details are in Chapter 4, Importing and Exporting

Searching
It's easy to search for a particular name in your SBook file.  Just type in the search
As you type, all the names that match what you have typed so far will be shown i
matrix, if there is room for them.  If a lot of names match what you have typed, they
still appear in the matrix but you will have to scroll to see them all.

In the message field just above the matrix, a number appears indicating how many 
(out of the total number of entries in the file) currently match the search request.  On
matching names will appear in the matrix.  If there is only one such name, it will be a
matically selected, and its corresponding entry will be displayed.  Otherwise, to displ
entry, just select its name with the mouse.
SBook: Simson Garfinkel’s Address Book 7
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After you have typed some text and narrowed the search to one or a few entries,
spacing through the search field expands the search automatically to the larger set.
you have backspaced completely through the search field, the matrix will again hold a
entries in the file, and you can try a completely new search.

+ Another way to try a new search is to select all the words in the search fiel
choosing Edit>Find  (command-f), or double- or triple-clicking on the search
field.  Then replace them by typing the new search string.

Search methods

Just below the search field, on the right, there is a pop-up menu that allows you to c
between three different search methods: word matching, phonetic search, and fu
search.

The search method described above is the default method, word matching.  Word matching
is an incremental search in which the letters you type are used to match the beginni
words.  Words may appear in any order, and case is ignored.  For example, all 
following search strings would match “Stone Design”: “stone,” “st de,” “S D,” and “d s

SBook provides another incremental search method, phonetic search.  This works like
word matching, except that each word is matched phonetically: “Lighthouse Design” c
be found by typing “lite” as well as “light.”

Full text search

SBook also enables you to make a full text search.  When you select the full text option
instead of searching through the names of the entries only, SBook will search throu
the full text of each entry.  

+ Because full text search takes a little longer than the name-only search des
above, SBook does not search incrementally when the full text option is sele
Press return to execute each search while you are in full text mode.

As an example, suppose I want to find all the software developers in Albuquerque.  I 
the full text option, type “albuquerque” into the search field, and press return.  Two en
are found, so I select the one I am most interested in viewing:

search method menu
8 SBook: Simson Garfinkel’s Address Book
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Note that the the text I searched for, “albuquerque,” is highlighted in the displayed re
The highlighted text is now selected, not the whole entry.  This allows you to cut, c
paste over, or type over this text on your next action. 

+ If you are in the process of copying and pasting whole entries, you may find
counter-intuitive, because clicking on the name of the entry displays the entr
does not select it.  If you want to select the whole entry, you must click again on
the name of the entry in the matrix.  Click twice to select a whole entry while yo
are in full text mode.

Finding entries by range

SBook also allows you to find entries based on the time that they were created, last 
fied, or last viewed.  Select Edit>Find by range to bring up a range selection panel.  Set
the panel for the range you desire, then click OK  (or press return).  The entries within th
range you have set will be displayed in the main SBook window just as with any se
(Full details on the use of this panel given in  “The Range Selection panel” in Chapte
SBook: Simson Garfinkel’s Address Book 9
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Using icons
SBook’s icons are for more than just good looks. You can click on them to make S
print envelopes, send email, and dial the phone.

+ For a discussion of how icons are inserted, and how to control icon insertion
“Parsing and icon placement” in Chapter 2.

Printing envelopes

To print an envelope from SBook, first find the person you want to address it to, then
on the envelope icon next to the address you want to use.  SBook will open a print
showing you the envelope exactly as it will be printed. 

The print panel is editable, so if you have any changes you want to make, you can
them right on the envelope face.  For example, you will notice that a default return ad
appears in the upper left corner of the envelope.  You will probably want to change
address.  Go ahead and edit it, on the print panel, until you are pleased with it.

When you are ready to print the envelope, slide the envelope, face up, into the manual feed
slot on your printer, and then click on Print .

+ Even though you are using manual feed, do not set the pop-up menu in the box
labeled paper feed to Manual, or the envelope will not feed through properly!

Below the envelope, on the bottom of the print panel, there are several controls that
you to select and save different return addresses, change the envelope size, log env
and control whether or not SBook prints barcodes at the top and bottom of the envel

default return address

standard print controls

name of entry

address next to icon
10 SBook: Simson Garfinkel’s Address Book
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The box labeled stationery contains a pop-up menu that allows you to select betw
different return addresses.  When you have changed one of these addresses by editi
the envelope print panel, you can click on either the Save button or the Save as... button to
save the changes.

+ Return addresses are saved as files in a certain directory.  When you sa
address, you must save it in this directory, because the addresses appearing on 
default address pop-up are exactly those stored in this directory.  The locati
this directory can be viewed and changed on SBook’s Preferences panel: see
Envelopes subview” in Appendix A: SBook’s Menus and Menu Commands.

The pop-up menu in the box labeled envelope size allows you to select either a standar
envelope, or a mailing label.

The checkbox labeled Print barcode determines whether SBook prints barcodes at the 
and bottom of the envelope, based on the zip code.

The box labeled Log after printing  allows you to log this envelope to a file or email.

+ To log to a file, you must first set a log file.  See Chapter 6, Logging what you do
with SBook.

+ You can also make bulk mailings with SBook by printing pages of mailing lab
See Chapter 5, Making Reports with SBook.

Dialing the phone

SBook can dial the phone for you, using either a modem or your NeXT computer’s int
speaker.  By default, SBook dials the phone with the speaker.  

+ If you want to use your modem to dial the phone, you will need to make sev
changes to SBook’s dialing preferences.  See Chapter 3, Dialing the Phone with
SBook, for details.

To make a phone call, pick up the phone and point it towards the NeXT computer’s int
speaker.  You will need to hold the phone near enough to the speaker to ensure that t
quality is good enough to dial the phone. You may need to experiment with different pl

+ On a monochrome system, the speaker is located at the back of the monito
a color system, the speaker is located on the sound box.

default address pop-up
envelope size pop-up

manual logging buttonsave address buttons barcode control
SBook: Simson Garfinkel’s Address Book 11
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Then click on the icon next to the phone number you want to dial.  SBook will immedia
begin dialing the phone.  Telephone dialing tones will be played through the speaker, 
sponding to the digits in the phone number.  A panel labeled Dialing panel will appear on
the screen while SBook dials.

You can cancel the call with the Cancel button, or make a log of this call with the Log
button.  

+ More information about logging your calls can be found in Chapter 6, Logging
what you do with SBook.

Sending email

To send email to someone from SBook, first find and display the person’s entry, then
on the email icon next to the address you want to use.  The Mail application will be not
and a pre-addressed Send window will appear on your screen:

+ You can also make bulk email mailings with SBook.  See Chapter 5, Making
Reports with SBook.

phone number next to icon

button to log this call

button to cancel this call

email address next to icon

name of entry
12 SBook: Simson Garfinkel’s Address Book
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Fine-Tuning Your SBook Files

Once you know something of how to work with SBook files and start to use SBook m
frequently, you may start to find that SBook’s understanding of the structure of name
addresses doesn’t quite correspond with yours.  Perhaps SBook misinterprets 
addresses in your file, or sorts the file differently from the way you would prefer. 
perhaps you would prefer to see names in italics and comments in boldface, rather th
other way round.

SBook provides plenty of ways to refine entries and files so that formatting is just how
like it, icons are just where you want them, and names are sorted just as you woul
them by hand.  This chapter explains how to modify your SBook files to suit you perfec

SBook’s Inspector Panel
When you make changes to an SBook file, you probably would like the file to be mod
in one of three ways:

• an individual change modifies a single entry;

• a global change modifies all of the entries in the SBook file;

• a change to the default modifies all new, yet-to-be created entries.

SBook allows most changes to be done at any of these three levels.  

+ You can also make a change to your preferences.  Such a change will affect the
way SBook behaves in general, regardless of what file you are looking at.  
section does not cover changes to SBook’s preferences: refer to “The Prefer
panel” in Appendix A: SBook’s Menus and Menu Commands for more
information.

Some changes, such as formatting changes to an individual entry, can be done fro
menus (and their associated keyboard equivalents).  Most changes at the global and
levels, however, must be done from the SBook Inspector panel.  You can bring up this
by going to the Tools menu and choosing Inspector...
SBook: Simson Garfinkel’s Address Book 13
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The Inspector panel has three subviews: File, Template, and Entry .  Changing the pop-up
menu at the top of the panel allows you to switch between the subviews.

Like the Inspector panels in other NeXT applications, this panel remains on your s
until you click its close box or leave the application.  The name of the file correspondi
the currently selected window is displayed across the top of the panel.  Additionally, i
Entry  subview, the name of the entry appears just below the pop-up menu.  This a
you to verify which file and which entry you are currently inspecting.  

The contents of the panel reflect characteristics of the current file, and in the Entry
subview, the  currently selected entry within that file.  You can use the Inspector pa
examine and change these characteristics.
14 SBook: Simson Garfinkel’s Address Book
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Sorting and sort order
A correctly sorted SBook file is not only convenient when you are scrolling through na
in the matrix; it is helpful when you want to print out mailing labels, and essential w
you want to print address books.  SBook provides several features to help you keep a
files sorted in the way you prefer.

Re-sorting

If a file has become unsorted due to adding or changing entries, you will want to re-s
Choose File>Sort entries to re-sort the file.  This may not solve all sorting problem
however.  If the file is still sorted incorrectly, you will need to examine and change the
order for individual entries or for the entire file.

Individual sort order

In a typical SBook file, names will appear in many different formats:

• Halloween K. Peabody

• Peabody and Associates, Inc.

• Lester R. Peabody, PhD

• The Peabody Savings and Loan 

If these names were in my address book, I would probably want all of them to ap
together, under “P.”  But if they were all sorted by first word, or all sorted by last w
each would appear under a different letter.  Because each name is in a different forma
name needs to be sorted in a different way so that they can all appear together.  Ins
requiring all the entries in your file to be sorted the same way, SBook maintains a se
sort order for each individual entry.

You can view and change the sort order for individual entries in the Inspector.  Brin
the Inspector by choosing Tools>Inspector... and set the pop-up menu at the top of th
panel to Entry .  The top part of the panel shows a pop-up menu which controls the
order for the current entry, and below the pop-up menu, the word this entry is sorted

entry name

sort word

sort order
SBook: Simson Garfinkel’s Address Book 15
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The pop-up menu allows you to choose between five different sort options:

• First word :  Used for names like "Peabody and Associates, Inc."

• Second word:  Used for names like "The Peabody Savings and Loan"

• Second to last word:  Used for names like "Lester R. Peabody, PhD"

• Last word:  Used for names like "Halloween K. Peabody"

• Smart sort:  When this option is chosen, SBook tries to guess which word in
entry is appropriate for sorting.

After you manipulate the pop-up menu, the sort word automatically changes so that yo
see if this entry will be sorted correctly.  This is especially helpful when “smart sor
chosen, since SBook’s guess may not correspond to your preference.

When you have made individual changes to all the wrongly sorted entries, you will wa
re-sort the file, since SBook does not do this automatically after each individual chan

Default sort order

The default sort order for a file controls how entries are sorted when you do not spec
individual sort order.  By default, the default sort order is “smart sort.”  

+ We find that “smart sort” works quite well for files with mixed contents, whe
the names of the entries may have any of the formats described in the pre
section.  Other sort orders are not as useful unless the names in a file are all
same type, such as only personal names (which are usually sorted by last wor
or only businesses (which are usually sorted by first word).

You can change the default sort order for the file, or apply a global change to the file,
the Template section of the Inspector, at the bottom of the panel.

Changing the default sort order for the file will affect only new entries to the file.  Exis
entries will not be changed.

If you want to change the sort order for all the existing entries in the file, set the pop-
the sort order you prefer, then click on the Apply to all entries button.  All the entries in
the file will be changed.

+ If you have made any changes to correct the sort order for individual entries, they
will all be overwritten by the default sort order when you click on this button.

SBook automatically re-sorts the file after it has changed all the entries to use the de

sort order menu

global apply button
16 SBook: Simson Garfinkel’s Address Book



2:  Fine-Tuning Your SBook Files

ation in
ttern.
 make
ext to

t never

hecks
 in the

 up in
 it is
 right
Parsing and icon placement
SBook recognizes names, addresses, and phone numbers by comparing the inform
each entry with a pattern.  But your entry doesn’t have to conform to a single, rigid pa
SBook has a large repertoire of patterns built into it, and uses the patterns it knows to
“intelligent guesses” about your text.  After it has made the guesses, it places icons n
all the addresses and phone numbers in your entry.  We call this process parsing.  

Reparsing

SBook is designed so that it parses an entry whenever parsing is needed.  It is almos
necessary to tell SBook to parse an entry.

SBook parses each new entry while you type it in.  After each line is entered, SBook c
to see if you have entered an address or telephone number.  When you have typed
entire entry, it will have been parsed completely.

SBook automatically recognizes when an entry needs to be reparsed:

• when parts of an entry have been edited

• when you have changed SBook’s parsing options

• or when an imported entry has never yet been parsed

and reparses the entry automatically the next time the entry is displayed.

Sometimes when you are in the middle of editing an entry, icons can temporarily end
the wrong places.  Although SBook will reparse the entry correctly the next time
displayed, you can also reparse the entry manually so that you can see how it will look
away.  Choosing Format>Icons>Parse entry (command-P) will reparse any displayed
entry.

this entry parses to
SBook: Simson Garfinkel’s Address Book 17
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Adding icons

Sometimes, you and SBook might disagree on whether a particular block of text look
a name, address, or telephone number, or just some comments.  For example, you 
working in a corporate or university environment where internal mail has an unu
address format, like “NE43-429,” and you still want to print envelopes using this add
format. Or you might have a friend in a faraway country with a very different teleph
number format, one that SBook doesn't know, but you still want to be able to use SBo
dial this number.

In this case, go to the Format menu and choose Icons.  First make sure SBook has done i
best to parse this entry, by clicking Parse entry.  If SBook still can't recognize your unusu
ally formatted address or phone number, place the cursor to the left of the text you w
mark with the icon, and then click on Insert icon of the appropriate variety.

+ If SBook cannot recognize a telephone number, it probably does not know the
correct dialing rules for that number.  In addition to inserting an icon next to
number, you may have to instruct SBook to dial this number in a special way.
“Dialing unusual numbers” in Chapter 3 for details.

+ If you want to create an entire file with addresses or phone numbers in a no
standard format, and you don’t want to insert icons manually for each entry
“Putting icons on the font template” on Page 22.

Removing icons

Generally, you won’t need to remove any of the icons that SBook inserts automati
Although it is possible for icons to end up in the wrong places after you have edite
entry, reparsing the entry will usually remove all of the misplaced icons.

However, manually inserted icons are treated differently from automatically inserted ic
When SBook reparses an entry or file, it will not remove these special icons.  If you 
to remove them, you must do it manually, in one of several ways:

place cursor here

then insert icon
18 SBook: Simson Garfinkel’s Address Book
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• You can remove icons one by one by selecting and deleting them in the usual 

• Or you can remove all of the icons from a selected entry, including the manu
inserted ones, by choosing Format>Icons>Remove all icons (command-R).  

• Or you can remove all of the icons from the entire file, including the manua
inserted ones, by choosing File>Remove all icons.

Although it is possible to delete automatically inserted icons, they will return as soon a
entry is reparsed. If any automatically inserted icons remain misplaced after deletin
reparsing, these icons are due to incorrect parsing, and must be suppressed, rather than
deleted.  The next section explains how to do this.

Suppressing icons

Generally, SBook knows which parts of the entry are comments, and which parts s
have icons placed next to them.  Sometimes, however, you might want to insist that SBook
treat certain parts of an entry as comments.  For example, you may want to store cred
numbers in an entry, and SBook may think they are telephone numbers and put tele
icons next to them.

By default, SBook assumes any text in italics is a comment, and does not try to pa
You can change SBook's behavior in the SBook Inspector. Bring up the Inspect
choosing Tools>Inspector... and set the pop-up menu at the top of the Inspector to File.

The part of the panel labeled parsing control contains four checkboxes that control whic
parts of an entry or a file are treated as comments.

• Checking the box labeled Do not parse italic causes SBook to treat italic text a
a comment.  This is the default.

• Checking the box labeled Do not parse bold causes SBook to treat bold text as
comment.

• Checking the box labeled Do not parse after blank line causes SBook to treat al
text after a blank line as a comment.

• Checking the box labeled Do not parse anything in this file prevents SBook from
parsing any part of any entry in the file.  You will have to insert all icons by ha

More than one box may be checked, and the effects of both will be combined.  For exa
you could have SBook treat both italics and boldface as comment fields.
SBook: Simson Garfinkel’s Address Book 19
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If you don’t want to change SBook’s behavior for the file as a whole, but you do wa
keep SBook from placing icons in a particular entry, set the pop-up menu at the top 
Inspector to Entry , select the entry in which you want to suppress icon placement, 
check the box labeled Do not automatically parse entry:

+ Use of the box labeled Dial numbers in entry exactly as shown is explained in
the section “Dialing unusual numbers” in Chapter 3.

You can also use the Inspector to suppress the display of icons, rather than their placemen
Set the pop-up menu at the top of the Inspector to File.  The three checkboxes in the pa
labeled icon display control whether icons are displayed in this file.  By default, all thr
are checked, but if you prefer not to see icons of a particular type displayed in this file
can uncheck the boxes.

Font and formatting
SBook generally doesn't care how you format the information you store in it.  You
change the font and formatting for any part of an entry, and SBook will still know whe
place the icons.  (There are a few exceptions to this rule, such as designated commen
see “Suppressing icons” on Page 19 for more detail.)

If you want to make an individual change to the font, size, and formatting of an entry
use the Format menu.  Use the Font submenu to change the font, and the Text submenu
to change the ruler.  These two submenus work just as their counterparts do in other
applications:

• The Font submenu allows you to use bold, italic, underline, superscript 
subscript.  You can also adjust the size and weight of text from this menu, and
can copy and paste fonts.  Or you can call up the Font Panel (command-t) to find,
preview, and set the font you want.

• The Text submenu allows you to set the tabs and change the alignment (left, r
or center).  You can also view, copy, and paste a ruler from one place to ano

click here to suppress icon placement for this entry
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Formatting the default template

If you want to make a font or formatting change to the default for new entries, you ca
the SBook Inspector.  Choose Template from the pop-up menu at the top of the Inspect
panel and edit the default template just as though you were editing an individual entry
can make font and formatting changes, or textual changes.

Once you have changed the template, all new entries for that file will use the templa
their initial contents:

You can also make a global change from this panel.  Clicking on the Apply to all entries
button with the mouse will cause all of the entries in the file to reflect the font and for
ting changes that you have made to the template.  A panel labeled Work in progress... will
appear while the changes are being made.

+ When a global change is applied, only the font and formatting characteristic
the first two lines are applied to entries: the first line’s characteristics are app
to the name of each entry, and the second line’s characteristics are applied
rest of each entry.  Also, if a single line contains several different fonts, only
first font on that line will be applied.

modified template new entry created with 
command-n after modifying 
template

global apply button
SBook: Simson Garfinkel’s Address Book 21
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Putting icons on the font template

If you are working in a university or corporate environment, you may need to send m
internal addresses that are not at all like standard postal addresses, or make phone
internal telephone numbers that are not at all like standard telephone numbers
example, at MIT, the internal mail system only requires a person’s name, a building 
and an office number, and the internal telephone system only requires a five-digit nu

Because SBook cannot recognize addresses and telephone numbers like these, on
you have is to insert icons individually next to each address or telephone numb
described in “Adding icons” on Page 18.  However, you may have so many non-sta
addresses and telephone numbers that this becomes inconvenient.

You can make an entire file in which addresses or telephone numbers appear in a no
dard format by placing one or more icons on the font template. These icons will ap
automatically in each new entry so that you do not have to insert them by hand.

+ Note in the above example that the telephone number part of the template
bold type, so that all the non-standard telephone numbers can by dialed exac
shown.  This is described fully in “Dialing individual numbers exactly as show
in Dialing the Phone with SBook.

The Colors panel

SBook also gives you access to a standard Colors panel so that you can change the 
text in an entry, or on the template.  Bring up the Colors panel by choosing Tools>Colors...
When you have chosen a color you like on the Colors panel, select some text in a dis
22 SBook: Simson Garfinkel’s Address Book
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entry.  Pick up the color from the color well on the Colors panel, then drop it onto
selected text.  The text will now appear in the color you have chosen.

+ If you drop a color onto an icon, all of the text associated with the icon will app
in the color you have chosen.

+ You can also cause an entire entry to appear in your chosen color.  If you d
color onto an entry that does not have selected text within it, the entire entry wi
appear in that color.

chosen color in color well

selected text

after dropping new color
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Dialing the Phone with SBook

If you make a lot of phone calls, you will probably find SBook’s dialing facility to be o
of your favorite features.  

• SBook can dial phone numbers for you with just one mouse click.

• Because SBook knows about US area codes and US dialing rules, it can dial 
numbers in the correct format for your area, even if they are written different
your address book.  

• SBook can dial the phone with your NeXT machine’s internal speaker, or with
modem that supports the Hayes AT command set.  

• Finally, SBook can log your calls to a file or email so that you have a record o
people you called and how long you talked.

This section covers SBook’s settings for dialing the phone.  It explains how SBo
dialing rules work, and how to modify them to suit your area.  It also explains how to
up and use the internal speaker or modem, depending on which you prefer.

We assume in this section that you have a basic familiarity with SBook’s dialing fac
If you don’t, you can find a quick description of how to use SBook to dial the phon
Chapter 1, Getting Started with SBook, on Page 11.  You may want to experiment wi
using the default settings to dial a few numbers before you continue with this section

+ This section also does not explain how to log your phone calls.  This is covered
Chapter 6, Logging what you do with SBook.
SBook: Simson Garfinkel’s Address Book 25
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Setting up SBook’s dialing rules
SBook is designed to allow you to store phone numbers in a variety of formats tha
natural for you, yet have SBook dial them in the correct way for your local calling a
Just like you do when you are dialing by hand, SBook decides how to dial a numb
using what it knows about the rules in your area.

SBook’s dialing rules are controlled by the Dialing rules section of the Preferences pane
Bring up the Preferences panel by choosing Info>Preferences... and select Dialing rules
from the pop-up menu at the top of the panel.  You will see one of two subviews:

Each subview presents a different set of dialing rules, corresponding to a different d
area.  The dialing rules pop-up menu, located just below the main pop-up on the P
ences panel, controls which view is active.  Choose the view from the pop-up tha
corresponds to your local dialing area and its rules.

+ The current version of SBook only contains specific rules for the United States
and Canada.  All other dialing areas must use Manual, the default.

Regardless of your dialing area, you will see a checkbox labeled Show dialed number at
the bottom of the panel:  

dialing panel for US & Canada

default dialing panel

dialing rules pop-up
26 SBook: Simson Garfinkel’s Address Book
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Checking this box allows you to determine if the dialing rules you have set are wor
correctly for your area.  Each time you dial a number, the exact digits that SBook dial
appear on the Dialing Panel.  While you are setting up your dialing rules, you will probab
want to have this box checked.  Once you become confident that your dialing rule
working correctly, you will probably want to have this box unchecked.

Dialing telephone numbers in the U.S. and Canada
SBook’s dialing rules for the U.S. and Canada distinguish between four types of num

• Local numbers are telephone numbers in your area code.  From most telepho
you can make a call to a local number by dialing:

seven digit number

• Long distance numbers are telephone numbers that are in an area code tha
different from your area code.  From most telephones, you can make a cal
long distance number by dialing:

1 + area code + seven digit number

• International numbers are telephone numbers that are not in the U.S. or Can
From most telephones, you can make a call to an international number by dia

011 + country code + city code + telephone number

• Special numbers are telephone numbers that are in your area code but that
cannot dial in the usual way.  These may be rural telephone numbers if you li
an urban area.  To make a call to a special number, you might need to dial:

1 +  seven digit number

You can control which numbers are treated as local, long distance, international, or s
numbers by changing the values in the area codes and special exchanges sections of the
Dialing rules panel.

The area codes section controls how SBook distinguishes between local and long dist
numbers.   Enter your area code in the field labeled current .  When SBook dials a number
it compares the number’s area code with your current area code to determine wheth
is a long distance call.

the number actually dialed is shown here

when this box 
is checked...
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+ By default, SBook assumes that any numbers written in an SBook file without
codes are located in the current area code.  SBook dials these numbers a
numbers.  If you prefer, you can specify a different area code for these number
by entering an area code in the field labeled default.

The special exchanges section controls which numbers are treated as special numb
These numbers can usually be identified by the exchange (the first three digits):

If you have any special exchanges in your area code, enter them in the special exchanges
section.  Special exchanges must be three digits long and may be separated by an
numeric character.

Local numbers with different prefixes

In some areas, you must dial a “1” before most or even all telephone numbers in you
code.  The dialing rules in these areas differ from the standard dialing rules in this w

• You must make calls to most local numbers by dialing:

1 + seven digit number

• You can call a few exchanges by dialing:

seven digit number

If you live in such an area, you can switch how SBook handles local and special num
In the dialing prefixes section, enter a “1” in the field labeled local, and delete the “1” in
the field labeled special.  In the special exchanges section, list all the exchanges that ca
be called without a “1” in your area code.  Now SBook will dial correctly for your area

There are a few areas in the U.S. and Canada where the area code must always be
even for calls in the same area code.  In these areas, the dialing rule for local numbe

• You must make calls to most local numbers by dialing:

1 + area code + seven digit number

If you live in such an area, enter a “1” and your area code in the field labeled local in the
dialing prefixes section.  Now SBook will dial all local calls with your area code, even
they are written as seven digit numbers in your address book.

exchange
(617) 354-7888
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Academic or corporate phone systems

In a typical academic or corporate phone system, you can make internal calls or calls
outside.  Internal calls usually only require an extension number to be dialed, which is
the last four or five digits of the seven-digit telephone number.  Calls to the outside us
require an initial number to be dialed to reach an “outside line.”

For example, the MIT phone system uses three exchanges within the 617 area cod
258, and 225.  Internal calls require only the last five digits of the seven digit phone nu
to be dialed.  External calls require a “9” to be dialed, then the outside phone number
rules for the MIT phone system can be summarized as:

• You can make calls to numbers in MIT exchanges by dialing:

five digit number

• You can make calls to other numbers by dialing, as appropriate:

9 + seven digit number

9 + 1 + area code + seven digit number

9 + 011 + country code + city code + telephone number

SBook can handle this situation easily.  

+ SBook allows you to insert a “d” in a dialing prefix to delete a leading digit of the
telephone number.  More than one “d” can be inserted to delete multiple dig

Using this special character, it is simple to encode the MIT rules: 

• The three exchanges used by the MIT phone system can be treated as special
exchanges.  Removing the first two digits of the seven digit number gives 
correct number to dial within MIT, so the special prefix should be “dd.”  

• An initial “9” should be added to the dialing prefixes for all other numbers.

The correct settings for MIT would look like this:
SBook: Simson Garfinkel’s Address Book 29
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Calling card numbers

From some telephones, you must dial every long distance or international number by
a telephone calling card number.

+ If you do not need to dial every number by using a calling card number, ref
instead to “Dialing unusual numbers” on Page 31.

The calling card dialing rule for long distance numbers might be:

• You must make calls to long distance numbers by dialing:

0 + area code + seven digit number, <wait for tone>, calling card number

The calling card dialing rule can be encoded into SBook’s long distance prefix, using two
special characters:

+ Inserting a comma in a dialing prefix causes SBook to pause briefly at that p
then dial the rest of the number. 

+ Inserting an “@” in a dialing prefix causes SBook to dial the telephone numb
that point, rather than at the end of the prefix.

Therefore, the long distance prefix should be “0@,” and then the calling card number.

As an example, for the calling card number 617-354-7888-1234, the correct long distance
and international prefixes would be:

If you find that SBook is not pausing long enough, add another comma or two.

Extension numbers

Some people in your address book may not be reached directly by dialing a telep
number.  You may need to dial a telephone number and then ask for an extension n
to reach a person’s office.  Although some phone systems still require that you talk
human operator to request an extension number, many systems will allow you to di
extension number so that you can reach a person’s office phone automatically.

Or you may need to dial a one- or two-digit extension number to choose between dif
departments in a company.  For example, you can reach NeXT Computer’s service d
ment by calling NeXT, then dialing a “4” when the automated phone system answers

The dialing rule for such a system may work as follows:

• You can make calls to numbers with extensions by dialing:

telephone number, <pause>, extension number
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SBook handles this rule automatically.  When you type a number in your address boo
can add an extension by typing “extension” (or an abbreviation like “ext.” or even “x”), 
then the extension number.  Then when you click on the telephone icon next to the nu
SBook will dial the telephone number, pause for a moment, and then dial the extens

+ Some phone systems that use extension numbers may require you to dial a s
non-numeric character (either “*” or “#”) before or after the extension numb
You can put the characters “*” and “#” in an extension, and SBook will dial the

+ If you find that a particular phone system requires a longer pause than S
normally inserts between the telephone number and the extension, you ca
one or more commas just before the extension number:

Dialing unusual numbers
Regardless of the dialing rules you have set up, there may be some numbers that
follow any rule and must be dialed in an unusual way.  These may be telephone nu
that require special handling, or they may be access codes of some kind.

• For example, you might want to put your telephone calling card number in
SBook file so that you can have SBook dial the code for you if you need to m
a call using the card number.

• Or you might always want to dial a particular telephone number by using a ca
card or making a collect call, rather than dialing direct.

If you try to dial unusual numbers as though they were regular telephone numbers, S
will try to interpret them according to its dialing rules, and might add or remove dig
Instead, you can tell SBook that an individual number, or all the numbers in an entry o
must be dialed exactly as shown.  This is done by using the SBook Inspector.

+ Refer to Chapter 2, Fine-Tuning Your SBook Files, if you need a complete
description of the Inspector and how to use it.

extension numbers

commas cause SBook to pause longer
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+ You should use this method only as a last resort, because it causes SBook to ignore
all of its dialing rules when dialing the affected numbers, and makes the file l
portable.  For example, in “Academic or corporate phone systems” on Pag
instead of writing MIT numbers in the SBook file as seven digit numbers w
special exchanges, we could have marked them to be dialed exactly as show
then they could not have been dialed from non-MIT telephones.  Writing the 
numbers as seven digit numbers with special exchanges allows the file to be
outside of MIT without any modification.

Dialing individual numbers exactly as shown

To mark individual numbers in a file to be dialed exactly as shown, you can ente
numbers in bold, and have SBook dial all bold numbers exactly as shown.

By default, bold numbers are dialed like any other telephone number, so you need 
the SBook Inspector to tell SBook that bold numbers in this file should be dialed as shown
Each file containing numbers that you want to mark in this way must be modified, u
the SBook Inspector, so that it will treat bold numbers specially. 

Make sure the file you want to modify is selected on the screen, then bring up the Ins
by choosing Tools>Inspector...  The name of the file should appear at the top of the pa
Choose File from the pop-up menu just below the filename.  At the bottom of the F
subview, there is a box labeled dialing control  containing two labeled checkboxes:

Check the box labeled Dial numbers in bold as shown.

Now you can mark an individual number to be dialed exactly as shown.  After enterin
number where you would like it to appear in your SBook file, select the number and ch
Format>Font>Bold (command-b).

+ Although the written label next to the number need not appear in bold, the first
digit in the number must be bold for SBook to consider it as a “bold number.

bold numbers to be dialed as shown

this number is not a “bold number”
32 SBook: Simson Garfinkel’s Address Book



3:  Dialing the Phone with SBook

 mark

 sure
 bring

 panel,

n.  

y to

own.

er’s

tional
Book

hold
ake a
Dialing all of the numbers in an entry or file exactly as shown

Instead of marking each individual number that you want dialed as shown, you can
an entire entry or file.  This tells SBook to ignore all the dialing rules it knows for all of the
numbers in this entry or file.

If you want all the numbers in a particular entry to be dialed exactly as shown, make
that the entry is selected or the insertion point is inside the entry in the display, then
up the SBook Inspector by choosing Tools>Inspector...  Choose Entry  from the pop-up
menu at the top of the panel.  The name of the entry should appear near the top of the
just above the section labeled Sort word.

At the very bottom of the panel, there is a checkbox labeled Dial numbers exactly as
shown: 

Checking this box will cause SBook to dial the numbers in this entry exactly as show

+ The entry itself will not appear any differently when displayed, so the only wa
tell if an entry is marked this way is to bring up the Inspector.

If you want all the numbers in this file dialed exactly as shown, choose File from the pop-
up menu at the top of the Inspector panel.  Just below the checkbox labeled Dial numbers
in bold as shown, you will see a checkbox labeled Dial all numbers exactly as shown:

Checking this box will cause SBook to dial all of the numbers in this file exactly as sh

Setting up SBook’s dialing method
SBook allows you to use either of two dialing methods: dialing with your NeXT comput
internal speaker, or dialing with your modem.  

Dialing with the internal speaker (the default) is easier to set up, requires no addi
equipment, and makes a great demo for your friends.  If you don’t make calls with S
very often, you will probably want to continue to use the speaker.

Dialing with the modem is more reliable, more versatile, and doesn’t require you to 
the phone up to the speaker every time you make a telephone call.  If you plan to m
lot of calls with SBook, you may want to start using a modem.
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You can select and set up your preferred dialing method from the Dialing method subview
of the Preferences panel.  Bring up the Preferences panel by choosing Info>Preferences...
and select Dialing method from the pop-up menu at the top of the panel.  

On the left side of the Preferences panel, there are two radio buttons that allow you to
a dialing method.  Click on the button corresponding to the method you prefer.  The h
the panel that you have selected will then be activated, and the other half will be graye

Dialing with the internal speaker

This is the method described in Chapter 1, Getting Started with SBook.  When you have
your preference set to dial with the internal speaker, you hold the phone up to the sp
and SBook produces tones to dial the phone.

These tones are controlled by the top half of the Dialing method panel.

dial through 
speaker, or 
modem?

modem controls

speaker controls
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The three slider switches control the tones produced by the speaker.  You probably w
adjust the sliders so that the tones are slow and loud enough to dial your phone, but f
quiet enough that it is not unpleasant to have them played by your speaker.

• Adjusting the Tone time affects how long each tone lasts.

• Adjusting the Gap time affects how much time passes between tones.

• Adjusting the Volume affects how loudly the tones are played.

You can click on the button labeled Test to play a short sequence of tones so that you c
hear how the tones will sound when SBook dials, and determine whether they di
phone correctly.  The test sequence is 555-1212.

Dialing with your modem

When you use a modem to dial the phone, the modem is attached to your voice l
parallel with your telephone.  SBook sends commands to your modem which cause it 
the phone directly, then hang up.  You pick up the phone before the modem hangs u

If you already use, or plan to use, a modem for data transmission (outgoing faxe
connecting with other computers) we recommend that you attach a second modem devoted
to dialing the phone for your voice line. You’ll probably want to use a cheap one, sinc
it will be doing is dialing the phone for you.  An old 300 baud modem will do just fine

+ If your existing modem is used for incoming faxes, you must use a modem devoted
to SBook dialing, because incoming faxes block the modem.

Attach the modem, with a standard NeXT modem cable (available from NeXT Conne
or Computer Attic), to one of the serial ports on the back of your NeXT.  Then plug
modem into your voice line in parallel with the phone.

+ Don’t plug your phone into the back of the modem!  Modems aren’t designe
be used with a voice line, and some cut off the phone’s connection while the
operating.  Use a “T” connector to attach the modem in parallel with your phone.

Once you have attached the modem to your voice line, you need to set up SBook’s d
preferences. First change the radio button to Dial through modem.  The modem section of
the panel will become activated:
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The section labeled Configure modem controls whether your modem will automaticall
answer the phone when it rings.  The two buttons in this section, Answer and Don’t
Answer, send commands to your modem that will turn “auto-answering” on or off until
next time the modem receives one of these commands.

You should decide whether you want to turn auto-answering on or off depending o
kind of calls you receive on the telephone line you have attached to the modem:

• If this line receives voice calls, you need to make sure your modem will not answ
the phone.  Click on the button labeled Don’t answer.

• If this line only receives data transmissions, you probably do want your modem to
answer the phone.  Click on the button labeled Answer.

The field labeled Modem port determines the port that SBook uses to dial the phone.

• If you are using a modem devoted to SBook dialing, set modem port to
“/dev/ttya” or “/dev/ttyb” depending on whether your modem is attached to 
“A” or “B” serial port.  

• If you must share the modem between SBook dialing and your data transmiss
set modem port to “/dev/ttyda” or “/dev/ttydb.”

The field labeled  dial string  determines the commands that are sent to your modem w
you dial a number.  Within the dial string, the characters “%s” represent the phone nu
SBook will replace those characters when it dials a particular number.  For example, d
354-7888 with the dial string set to “ATDT%s,;H0” will cause SBook to send the st
“ATDT3547888,;H0” to the modem.

+ You probably will not need to change the dial string.  Refer to the owner’s ma
for your modem if you need more information on the commands in the dial str

The pop-up menu labeled modem baud rate determines the baud rate SBook uses when
communicates with your modem.  Set the pop-up to the baud rate you prefer.

Finally, whenever you make a phone call with your modem, there is a small amou
overhead involved in securing the modem port for your use.  If you check the box la
Lock modem after dial, SBook locks up the modem port between calls so that you d
have to secure the modem for yourself each time.  The modem is locked when you
the first call, and it is unlocked when you quit out of SBook.  You can unlock the mo
at any time by going to the Tools menu and choosing Unlock modem (command-U).

+ If you are using pulse dialing, we have found that it is usually necessary to 
the modem, because pulse dialing takes so much longer than tone dialing.

+ When the modem is locked, other people and other applications can’t use it. 
you are using your modem for data transmissions, or if other people on 
system are also making calls with this modem, you should leave the 
unchecked.
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Importing and Exporting

Once you start using SBook, you will probably want to import all of your existing add
databases so that you can use them as SBook files.  This section explains how to 
your existing files, as well as how to export SBook files to a variety of formats.

Importing files
We have tried to make it as simple as possible to import files into SBook so that yo
start using your existing databases right away with a minimum of conversion time.  
of your address databases should easily convert over to SBook format.  If you do
trouble, read “If importing fails” on Page 41.  Keep in mind that, in addition to techn
support, we also offer hand conversion as a service to our customers; contact us for 

To import a file, go to the File menu and choose Import...   If there is a currently selected
SBook window, a panel labeled Import  will appear asking if you want to import into tha
file, or create a new file.  (If there are no windows open, the panel will not appear.)  
on Current file  (the default), New file, or Cancel Import depending on your preference.

Another panel labeled Import  will now appear, allowing you to choose the source fil
This panel is just like a standard Open panel, except for a small section labeled Import
options near the bottom of the panel.  It is important to make sure the import option
set correctly.  (Import options are described in detail in the following two subsections, 
formats” on Page 39 and “File sources” on Page 40.)
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When you have chosen the file and set the options, click on the OK  button at the bottom of
the panel.  SBook will now start to import the file.  As the file is imported, you will se
panel displaying how many entries have been imported so far:

After the file has been successfully imported, SBook will inform you with an Alert pa
displaying the total number of entries that were imported.

Now you will want to check to make sure the file was imported correctly.  Check tha
number of entries corresponds to the number of records in the original database. 

import options section
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through the file and display a few entries to be sure that they appear correct in the f
all the information present in each entry?  Are the entries formatted properly, with ap
priate line breaks?

If any of these seem incorrect, you may have imported the file with the wrong option
the wrong file format is chosen, for example, the file may be imported as one large e
Readjust the options and try again, and if you still have trouble, take a look at “If impo
fails” on Page 41.

File formats

When importing a file, it is important to specify to SBook the format it is written in so t
it can be converted properly.  Make sure that the file format pop-up menu in the Im
Options section of the Import panel is set correctly for your file.

SBook can import files from the following formats, all of which are on the pop-up me

• SBook ASCII: An easy to read ASCII format in which SBook can export file
Entries are stored exactly as they appear in the display, line breaks and all, e
that instead of Rich Text they are plain ASCII.  Entries are separated from 
other by lines of equal signs.

• SBook binary: This is the format that SBook document files are written in. W
use NeXTSTEP’s “typedstream” facility, so you can easily move SBook bin
files between NeXTSTEP on a NeXTstation and NeXTSTEP/486 without 
conversion.

• QuickDEX : A format used by QuickDEX, a popular Macintosh free-format da
base.  This format is very similar to SBook ASCII, except that different delime
characters are used.  SBook will automatically convert Macintosh graphical c
acters to their corresponding Display PostScript characters on import.

• Tab delimited: A format used by DataPhile and most Macintosh-style databa
Generally, the first line of the database contains a list of field names.  Each s
quent line corresponds to one record, in which the fields are separated by
Fields that contain the “tab” character must be enclosed by quotation marks

• Mail-merge: A format used by dBase and most PC-style databases.  This is
tab delimited except that the fields are separated by commas rather than
Fields that contain commas must be enclosed by quotation marks.

file format menu
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If you choose Tab delimited or Mail-merge, the box labeled First record contains head-
ings will be activated (it is normally grayed out).

Checking this box will cause SBook to assume that the first line of your database co
a list of field names, preventing it from erroneously importing that line as a separate 
In addition, SBook will try to make sense of the field names as best it can, so that the
base will be formatted in a reasonable way once it is imported.  If the database co
separate fields for area code and telephone number, for example, or for first and last 
SBook will concatenate the parts together so that they do not appear on two separat

Finally, if your file does not seem to correspond to any of the five formats that SB
supports, try going back to the database program that created the file and exportin
different format.  Most database programs can export in at least one of these forma
you cannot find a format common to your database program and SBook, skip t
importing fails” on Page 41.

File sources

Another option you need to set when you import a file is the source.  A file that is created
in Macintosh file format, for example, has a slightly different character mapping from
that is created on the NeXT or under Unix.  In order for SBook to do the conversion
must make sure that the correct file source is chosen.

You may not need to set this option manually, since some file formats cause SBook 
the file source automatically:

• If you have chosen either SBook ASCII or SBook binary file format, the file
source is automatically set to be NeXT.

• If you have chosen QuickDEX  file format, the file source is automatically set t
be Macintosh.

However, if your file differs from SBook’s assumptions, you will have to set this opt
yourself.  Choose the source that most closely corresponds to the system your fil
created under.

check this box if appropriate

file source menu
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If importing fails

If the number of records in the original database does not correspond to the numb
entries imported, or each entry appears on one long line, or characters in the file appear
incorrectly (especially accented or other special characters):

1. You probably have set the file format  and/or file source pop-up menus incor-
rectly.  Check these settings and try again.

2. If you cannot get the file to import correctly by correcting the settings, your 
may be in a format that SBook cannot import, or the file may be corrupted. 
exporting the file again from the original database application.  You may be 
to find a different export format that can be imported by SBook.

If entries appear to be mixed up, with parts of the name, address, or phone num
appearing in the wrong order, or line breaks are too frequent, with each entry appearing  in
too many broken up lines:

1. The file is probably in either tab-delimited or mail-merge format, and the fie
are not set up conveniently for SBook.  Try exporting the file again from the o
inal database application.  You may be able to concatenate or rearrange fie
that when your file is imported, it will appear more as you desire.

2. If you cannot get the fields rearranged by exporting the file again, take a lo
the file with an editor like Emacs.  Note the delimiters (tabs or commas) separ
the fields.  Make a copy of the file, then try editing the copy, moving the fie
around and adding or removing delimiters.  You may be able to edit the file in
way so that it will look better once it is imported.

If all else fails, we will convert any database by hand for a nominal charge.  If we are u
to convert your database, or if we determine that the trouble you were having was du
bug in SBook, you will not be charged.  Contact us for details.

Exporting files
To export a file, make sure the file you want to export is open and selected, then go
File menu and choose Export...  (If there is no open and selected file, this menu option w
be grayed out.  Open the file you want to export and try again.)

Because you may not want to export all of the entries from this file, you will automatic
be presented with the Range Selection panel.  Choose a range from this panel and clicOK . 

+ For complete information on how to use the Range Selection panel, refer to 
Range Selection panel” in Chapter 5.
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Once you have selected a range, a panel labeled Export  will appear, allowing you to choose
the destination file for the export.  This panel is just like a standard Save panel, exce
a pop-up menu labeled Format at the bottom of the panel, which allows you to choose 
file format you want for the exported file:

Choose the destination file in the usual way, and make sure the file format pop-up m
set up in accordance with your preference:

• SBook ASCII: An easy to read ASCII format in which SBook can export file
Entries are stored exactly as they appear in the display, line breaks and all, e
that instead of Rich Text they are plain ASCII.  Entries are separated from 
other by lines of equal signs.

• SBook binary: This is the format that SBook document files are written in. W
use NeXTSTEP’s “typedstream” facility, so you can easily move SBook bin
files between NeXTSTEP on a NeXTstation and NeXTSTEP/486 without 
conversion.

• QuickDEX : A format used by QuickDEX, a popular Macintosh free-format da
base.  This format is very similar to SBook ASCII, except that different delime
characters are used.  SBook will automatically convert Display PostScript ch
ters to their corresponding Macintosh graphical characters on export.

file format pop-up menu
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+ You may notice that this list does not include tab-delimited and comma-delimite
formats.  Because the text stored in your SBook files need not fit into a r
pattern, SBook cannot export the records in a one-to-one way into a stan
database format.  That is, since each record need not consist of just a nam
address, and a phone number, for example, the records cannot be exported
format requiring just a name, address, and phone number.  

When you have chosen the destination file and set the file format correctly, click on thOK
button at the bottom of the panel.  SBook will now start to export the file.  As the fi
exported, you will see a panel displaying how many entries have been exported so f

After the file has been successfully exported, SBook will inform you with an Alert pa
displaying the total number of entries exported:
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Making Reports with SBook

SBook allows you to make three kinds of reports: address books, mailing labels, and
email mailings.  

• SBook’s address book report allows you to print address books and phone boo

• The mailing labels report allows you to print sheets of mailing labels.

• The bulk email mailing report allows you to create and use email mailing lists.

Although the final output from each of these three reports is very different, the proce
making them is very similar.  

To make a report with SBook, 

1. Select the SBook window corresponding to the file you want to use.

2. Choose the report type you want from the menu under Tools>Reports.

3. Select a range of entries that you want to use to build this report.  This st
described in detail in “The Range Selection panel” on Page 46.

4. SBook will now extract the relevant information and build the report.  This ste
described in detail in “Building the report” on Page 48.

5. View the report, scroll through it, modify it until it pleases you, and then print
address book or labels, or make the email mailing.  This step is described in 
in “Bulk email mailings” on Page 49, “Mailing labels” on Page 50, or in “Addre
books” on Page 52, depending on the kind of report you are making.
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The Range Selection panel
If you don’t want to use all the entries in the selected SBook file, you will need to sel
range.  To make this easy, the Range Selection panel will pop up automatically whe
tell SBook to build a report.

The Range Selection panel includes two subsections: the name range, and the time range.
Only those entries that are chosen by both the name range and the time range will b
included in the total range of entries.  The field labeled Entries selected at the bottom of
the Range Selection panel displays how many entries are included in the total range. 
you are finished selecting a range, click the button labeled OK  at the bottom of the panel,
or just hit return.  You can also cancel the range selection by clicking on the Cancel button.

Using the name range

The section of the panel labeled name range allows you to select a range of entries bas
on a previous search or selection.

• When the radio button labeled All names is selected, the name range includes 
of the entries in the file.

• When the radio button labeled All displayed is selected, the name range include
all of the entries that match the current search request and are currently disp
in the matrix.

• When the radio button labeled All selected is selected, the name range include
only those entries that are selected in the matrix.
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Using the time range

The section of the panel labeled time range allows you to select a range of entries bas
on when they were initially created, last modified, or last seen.

+ If you want to use the time range, you must check the box labeled Use time range
which is located just below the time range section.  If this box is left unchecked
it will not matter what values are set in the time range section.

The time range section consists of several pop-up menus.  You can select a time ran
manipulating these menus, and by entering a date in the numeric field.

Clicking on the SET TODAY  button below the time range section sets the month, date
and year in the time range section to today’s date.

4 names are displayed

1 name is selected

194 names are in the file
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Building the report
As soon as you have selected a range, SBook starts to extract the relevant informatio
the entries you have chosen:  

• For email mailings, SBook must extract all the email addresses from the file.

• For address books and mailing labels, SBook must extract all the postal addr
and telephone numbers from the file.

This is a slow process, so it will take time for SBook to extract this information and de
the report.  If the range you have selected contains a large number of entries, it may
few minutes.  While SBook builds the report, a panel labeled Work in progress... will
appear on the screen with a circular gauge showing you how many of the selected 
have been processed.  You can stop the process at any time by clicking on the button 
Cancel just below the circular gauge.

If some of the entries need to be parsed, SBook will parse the entries before continuin
the report.  This will slow down the report-building process.  A message will appear in
lower left-hand corner of the Work in Progress panel, informing you that SBook is b
parsing.  Once SBook has parsed the entries that need to be parsed, it will keep  inform
with the entries the next time the file is saved so that it will not have to do the parsing a
(For more information on parsing, refer to “Parsing and icon placement” in Chapter 2

Once the information has been extracted and the report has been built, a panel will a
on your screen allowing you to view the report and modify it.  Depending on which kin
report you chose, you will see a different panel.  The next three sections, “Bulk email 
ings,” “Address books,” and “Mailing labels,” explain how to use these three differ
panels to view, modify, and output reports.

SBook is parsing entries
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Bulk email mailings
The simplest kind of report is a bulk email mailing.  When SBook has built the bulk e
report, you will see a simple panel on the screen titled Bulk email.  This panel contains all
of the email addresses from the entries in the range you chose.  The number of add
appears in the lower left corner of the panel.

+ If an entry contains more than one email address, all of the email addre
contained in the entry will appear in the list, not just the first one.

You can scroll through the panel to view all of the email addresses.  Each addr
followed by the entry’s name in parentheses, just as if you had clicked on the email ic
send email to that address.  

If you wish to add, remove, or modify addresses before you make the bulk mailing, yo
edit the panel directly in the usual way.

Once you are satisfied with the addresses on the panel, you can use the output con
the bottom of the panel to make a bulk email mailing with these addresses.

• Click on Send (the default) to place the addresses in the To: field of a messa

• Click on Cc: to place the addresses in the Cc: field of a message.

• If you need to place the addresses in the Bcc: field of a message, or in a fi
make a mail alias, for example), click on Copy to copy them to the pasteboard.

• You can also click on Cancel if you prefer.

addresses in editable window output controls

scroll bar

number of addresses
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Mailing labels
When SBook has built a mailing labels report, you will see a panel on the screen la
Labels.  This is a complex panel with numerous controls that allow you to scroll thro
the labels, zoom in and out, change what is displayed, and change the format of the 

The left side of the panel contains a scrolling window so that you can view the labe
they will be printed.  A zoom control pop-up menu allows you to zoom in to view the la
up close, or zoom out to look at a whole page of labels.

scroll bars

number of labels number of pages zoom control pop-up

labels enlarged to 200%
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The right side of the panel contains controls for changing what is displayed and the f
of the labels.  As soon as you change the settings, SBook will immediately reforma
labels and display them.  This makes it especially easy to set up the format you 
because you can experiment with different formats until you find one you like.

Once you are happy with the labels and their format, click on Print  (the default), or Cancel.

Deciding what is displayed

The sections labeled Show and display labels allow you to change the information
displayed in the labels.  

• The settings in the section labeled Show determine whether the labels show
names only, addresses only, phone numbers only, or any combination of the 

• The section labeled display labels is only activated when you have set SBook 
show addresses or phone numbers in the labels.  Do you want to display only those
labels containing all the information you have selected to be shown, or do y
want to display all of the possible labels even though some of the people ma
have addresses or telephone numbers to show?

For example, if you want to print labels for making a bulk mailing, you will want to sh
names and addresses, but not phone numbers, and you will not want to display 
without addresses, so the settings shown in the illustration on the left would be corre

Deciding how the labels are formatted

All of the other sections on the panel determine the format of the labels.

The section labeled Sort key determines whether the labels appear sorted by name or 

The section labeled Address position determines where the name and address informat
appears on each label.  You can choose to have addresses appear at the top left of ea
or centered in each label.

The section labeled label margins allows you to have SBook print the labels with larg
margins, if you prefer.  SBook scales the contents of each label to fit within the marg

The section labeled labels per page allows SBook to account for different label format
You should enter the number of columns of labels in the field labeled width , and enter the
number of rows of labels in the field labeled height.

+ At this time, SBook can only design reports for labels that are all the same siz
extend to the edges of a standard letter-sized page.  Pages with labels of dif
sizes, or labels that do not extend to the edges of the page, will be handle
future version of SBook.

The section labeled Label Font allows you to change the font used for printing the labe
Clicking on the button labeled set brings up the standard Font Panel.
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Address books
When SBook has built an address book report, you will see a panel called Address Book.
This is an even larger and more complex panel than the Mailing labels panel; nevertheless,
because (like the Mailing labels panel) it allows you to experiment with its settings an
view the corresponding changes immediately, it is very easy to use.

The left side of the panel contains a scrolling window, which works just like the Mailing
labels panel, so that you can scroll through the address book and zoom in and out.

+ The lines that you see surrounding the parts of text in the window only appe
that you can easily see where SBook is laying out the fields for names, addre
and phone numbers.  The only lines that will print in the finished address boo
the dotted lines that link names to phone numbers.

The right side of the panel contains controls for changing what is displayed and the f
of the address book.  Most of the controls affect the format.

The section labeled Include is the only one that affects what is displayed.  Click on t
appropriate radio button to display addresses, phone numbers, or both.
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Choosing a format for the address book

The primary control for formatting an address book is the pop-up menu that appears
top of the section labeled Format.  This pop-up menu allows you to choose between f
different preset formats, or choose Manual to create a format for unusually sized pages

When you switch between the different preset formats on the pop-up menu, the settin
the rest of the panel that control formatting change to the defaults for the format you
chosen.  For example, the defaults for the Address book menu option (a format designed
to print full-size address books)  are shown on the illustration at left.

If you want to use a preset format, but you do not want to use all of the default setting
that format, almost all of the settings can be changed.  The only settings you cannot c
are those that control the size of the page; those settings are just below the pop-up
section labeled page size, and they are grayed out when a preset format is selected.

If you want to use a different page size, you must choose the last option on the m
Manual, and then adjust the page size settings to the sizes you require.

Refining the format you have chosen

The layout section at the top of the panel allows you to select the number of columns

The Fonts section allows you to change the fonts for names, addresses, and phone nu
Clicking on any of the three set buttons will bring up the standard Font Panel.

In the Format section, the units menu allows you to choose between inches, centimet
points, and picas.  There are also six fields that allow you to adjust formatting:

• The width  setting determines the page width.

• The height setting determines the page height.

• The margins setting determines the page margins.

• The gutter setting determines the space between columns.

• The phone number setting determines the width allocated to phone numbers

• The between entries setting determines the vertical space between entries.
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Printing and assembling pocket books

If you are printing an Address book, Day Planner, or Manual address book, you can prin
in the usual way, using the paper cassette.  But if you are printing a Pocket book, either
one-fold, two-fold, or three-fold, you will have to print in a special way.

Once you are happy with the pocket book as it appears in the window, click on Print  (the
default) to print the book.  You will be presented with a standard Print panel.

Printing a pocket book requires printing double-sided pages.  To do this, you must s
the paper feed pop-up to Manual.  Then click on Print  to start printing.

1. When your NeXT computer prompts you for the first page, feed a sheet of p
into the printer, using the manual feed slot.  

2. Wait for the sheet to come out of the printer, then feed the sheet of paper bac
the printer, with the same leading edge as before, but with the blank side up.

3. Repeat this process until the entire book is printed.

Once the pocket book is printed, you must assemble it.  SBook prints folding and sta
instructions right on the pages so that assembling is easy to do:

1. Find the dotted line labeled first fold  on the page.  Fold the page along that lin
so that the fold line appears on the outside of the fold.

2. If you are making a two-fold or three-fold pocket book, fold along the second fold
and/or third fold  lines in the same way as the first fold, always making sure t
the fold lines fall on the outside of the fold.

3. If your pocket book consists of more than one sheet of paper, fold all the s
the same way as the first.  Then stack all the folded sheets together, with a
final folds forming the “spine” of the book.  Make sure the sheets are stac
together in the right order, with page numbers coming out correctly.

4. On the outside of the final fold, you will see instructions to staple in two or three
places along the fold.  Staple all of the sheets together in the places indic
making sure that the top of each staple falls on the outside of the fold.

5. Using a pocket knife or a letter opener, slice open all of the folded pages e
for those along the spine.  You now have a completed pocket book!

paper feed pop-up
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Logging what you do with SBook

If you need to keep track of the people you call or write to, or how much time you sp
on the phone, you will want to use SBook’s logging facility.  

• SBook allows you to log the calls you make and the envelopes you print.

• You can also log memos or incoming calls by bringing up the log panel manu

• You can have SBook send you log messages in email, or you can create a l
that can be imported into a time-billing system or a general purpose databas

• You can make notes to yourself right on the log panel, and they will appear in
email or file, so that you can keep track of what was said and done.

Getting started with logging
The simplest way to get started with logging is to log your calls, letters, and other mes
manually.  You can log any message by bringing up the Log panel with a command, o
can click on the Dialing Panel, or the envelope print panel, to log calls or letters.

The Log panel

To log an incoming call, memo to yourself, billable time, or other miscellaneous mes
choose Tools>Logging panel... (command-l) to bring up the Log panel manually. 

send button

logging controls

time elapsed

stop and start timer

subject pop-up menu

message field for notes
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At the top of the panel, just under the close box, there is a timer with a stop/start but

By default, the timer starts running as soon as you bring up the Log panel.  You can
the timer at any time by clicking on stop.  Once it is stopped, you can start the timer aga
by clicking on start.  SBook will record the total elapsed time in the log.

The subject line of the Log panel allows you to define the category of what you are log
whether you are logging a telephone call, a message, a fax, or a reminder to yours
making a record of billable time.  You can change the subject line manually, or by cho
from the variety of preset subject lines on the subject pop-up menu:

Once you have chosen the subject line, you can fill in the person you called or other re
information in the From:  line and Subject: line of the Log panel:

timer is stopped; 
click start to start

timer is running; 
click stop to stop

menu of preset subject lines

subject line

chosen subject line

filled-in fields
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Fill in as many notes and other information as you wish in the scrollable message fie
the Log panel.  These notes will appear in the log, as well. 

+ If you want to make notes in Rich Text, you can check the box labeled NeXTmail
just below the Log to email button.

When you are ready to log this note and return to SBook, check the box labeled Log to
email next to the large button labeled SEND.  The SEND button will become activated:

+ Don’t check the Log to file button yet.  You cannot log to a file until you have
log file chosen in your Preferences.  Refer to “Choosing the default logg
method” on Page 60.

Now when you click on the SEND button, SBook will send this message to you in ema

no log method selected; 
send button is grayed out

log to email selected; 
send button is activated
SBook: Simson Garfinkel’s Address Book 57



6:  Logging what you do with SBook

d.
 you

le-

for-

 in the
Logging calls and letters manually

You can log any of your outgoing telephone calls by clicking on the Log button that appears
on the right side of the Dialing Panel:

The Log panel will appear, as before, but with the From:  and Subject: lines on the panel
filled in appropriately: 

• The From:  line is automatically filled in with the name of the person you calle
This is taken from the name of the entry associated with the telephone icon
clicked on to make this call.

• The Subject: line is automatically filled in with the message that you made a te
phone call to this person or organization.

• The message field of the panel is automatically filled in with all of the above in
mation, as well as the date and time that SBook began dialing.

After you have added any notes you need in the message field, make a log to email
usual way.  The message will include the elapsed time, as before.

Likewise, you can log the letters you send by clicking on the Log after printing  button that
appears in the lower right corner of the envelope print panel:

log this outgoing call

From: and Subject: lines are 
filled in automatically

Information about this call is 
filled in automatically

log after printing this envelope
58 SBook: Simson Garfinkel’s Address Book



6:  Logging what you do with SBook

his

tter

ress

l in the

other
mati-

your
other

 up the
As above, the Log panel will appear with the From:  and Subject: lines on the panel filled
in appropriately:

• The From:  line is automatically filled in with the name of the person you sent t
letter to.  If you edited the envelope panel before printing this envelope, the modi-
fied name from the panel, rather than the original name, will appear in the log.

• The Subject: line is automatically filled in with the message that you sent a le
to this person or organization.

• The message field of the panel is automatically filled in with the complete add
that you printed on this envelope.  Again, this is taken from the envelope panel,
not from the original entry.

After you have added any notes you need in the message field, make a log to emai
usual way.

Changing your logging preferences
Once you are familiar with the Log panel, and you start to log your calls, letters, and 
messages more frequently, you may want to have every call and letter logged auto
cally.  Or you may want to start logging to one or more files, so that you can import 
record of the people you called and the time you spent into a time-billing system or 
database.  To do these things, you will need to set up SBook’s logging preferences.

SBook’s logging preferences

SBook’s logging preferences are a subview of the Preferences panel.  You can bring
Preferences panel by choosing Info>Preferences...  To get to the Logging subview, choose
Logging from the pop-up menu at the top of the panel:

From: and Subject: lines are 
filled in automatically

Address this letter was sent to 
is filled in automatically

choose Logging to get to logging subview
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+ You can find more information about the Preferences panel in “The Prefere
panel” in Appendix A: SBook’s Menus and Menu Commands.

The Logging subview contains two sections:

• The section labeled calls and memos determines how SBook logs your telephon
calls and any messages you log by bringing up the Log panel manually.

• The section labeled envelopes determines how SBook logs your envelopes.

+ Since the two sections are so similar, this section will only explicitly show y
how to change the settings for calls and memos.  You can change the settings fo
envelopes in exactly the same way.

Choosing the default logging method

By default, SBook does not check either the Log to file or Log to email buttons on the Log
panel when it is brought up.  You must check the appropriate box yourself before you
on the SEND button to log the message:

these buttons are unchecked by default
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If you usually log to email, you can check the Log to email box on the Preferences pane
When this box is checked, the Log to email box on the Log panel is automatically checke
for you every time you make a call or memo. 

If you want to log to a file, you can check the Log to file box on the Preferences pane
When this box is checked, the Log to file box on the Log panel is automatically checke
for you every time you make a call or memo.

+ To log to a file, you must set a log file.  Click on the box labeled set next to the
field labeled file.  You will be presented with a panel just like a standard Sa
panel that is labeled Set telephone log file.  Once you have chosen a file, th
filename will appear in the file field.

If you want to log to a file and log to email, you can check both boxes.

Automatic logging

If you want to log all of your calls, you can select the radio button labeled Log all calls:

When the Log all calls button is selected, each time you make a call the Log panel 
come up automatically, just as though you had clicked on the Log button on the Dialing
Panel to log this call manually.
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Appendix A: SBook’s Menus and Menu Commands

This Appendix shows all of SBook’s menus and menu commands, and refers to the
of the main text in which they are described in detail.  This Appendix also covers SBo
Preference panel and its subviews.

The main menu

SBook’s main menu contains five submenus which are described in this chapter: theInfo
menu on Page 64, the File menu on Page 65, the Edit  menu on Page 66, the Format menu
on Page 67, and the Tools menu on Page 68.

The main menu also contains five other standard menu items, which are not descri
detail because they behave as their counterparts do in other NeXT applications:

• The Windows menu allows you to select and arrange SBook’s windows.

• The Services menu allows you to use services from other applications.

• The Print  command allows you to print a currently selected entry.

• The Hide command causes SBook to hide itself.

• The Quit  command causes SBook to close all files and quit.
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The Info menu

SBook’s Info menu allows you to get information about SBook itself, whether this cop
SBook is licensed, what version you are using, and your license agreement.  You ca
change your preferences from this menu using the Preferences... command, and you can
send us a suggestion or a bug report by using the Bugs & Suggestions... command.

• The Info Panel... command brings up SBook’s Info Panel.  This panel displa
copyright and version information, and a few acknowledgements.

• The Preferences... command brings up SBook’s Preferences panel.  This i
complex panel with many subviews.  It is decribed in detail in “The Preferen
panel” on Page 69.

• The License... command brings up SBook’s License panel.  You can read ab
the License panel and get information about your license agreement in 
License Panel” in Appendix B: Installing and Licensing SBook.

• The Legal... command brings up a panel which allows you to scroll throu
SBook’s single-user and network license agreements.  These agreemen
described and explained in “SBook Licenses” in Appendix B: Installing and
Licensing SBook.

• The Bugs & Suggestions... command notifies the Mail application to bring up 
new Send window, pre-addressed to us, so that you can send us your bug r
and suggestions.
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The File menu

SBook’s File menu allows you to do various things to files:

• The Open command (command-o) opens a pre-existing SBook document file
This command is described in “Opening files” in Chapter 1.

• The New command (command-N) creates a new SBook document file.  Th
command is described in “Creating new files” in Chapter 1.

• The Import...  command allows you to import files into SBook’s file format.  Th
command is described in “Importing files” in Chapter 4.

• The Export... command allows you to export files into other file formats.  Th
command is described in “Exporting files” in Chapter 4.

• The Sort entries in file command sorts all the entries in the currently selected 
according to the current sort order.  This command is described in “Re-sortin
Chapter 2.

• The Remove all icons command removes all the icons in the currently selec
file, including those that you have inserted yourself.  This command is descr
in “Removing icons” in Chapter 2.

• The Save command (command-s) saves the currently selected file.  Thi
command is described in “Saving files and making backups” in Chapter 1.

• The Save As... command (command-S) allows you to save the currently selecte
file under a different filename.  This command is described in “Saving files 
making backups” in Chapter 1.

• The Save All command saves all open files that need to be saved.  This comm
is described in “Saving files and making backups” in Chapter 1.

• The Revert to Saved command reverts the currently selected file to the last sa
version of that file.

• The Close command closes the currently open file.  This command is describe
“Closing files” in Chapter 1.
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The Edit menu

SBook’s Edit menu allows you to create, search for, and modify SBook entries:

• The Cut command (command-x), Copy command (command-c), and Paste
command (command-v) are the standard NeXT commands that allow you to c
copy, and paste entries and information.  They are described in “Using cut, c
and paste” in Chapter 1.

• The Find  command (command-f) selects the contents of the search field so th
you can begin a new search.  It is described in “Searching” in Chapter 1.

• The Find by range command brings up the Range Selection panel so that you
search for entries within a given range.  This command is described in “Search
in Chapter 1, and the Range Selection panel is described in “The Range Sel
panel” in Chapter 5.

• The Revert entry command (command-U) reverts the currently selected an
displayed entry to its last saved version.

• The New entry command (command-n) creates a new entry in the currentl
selected file.  It is described in “Adding new entries” in Chapter 1.

• The Delete entry command (command-D) deletes the currently selected entry o
entries.  It is described in “Deleting entries” in Chapter 1.

• The Spelling... command (command-:) and the Check Spelling command
(command-;) allow you to check the spelling of words in an SBook entry.

• The Select All command (command-a) selects all the entries in the currentl
selected SBook file.
66 SBook: Simson Garfinkel’s Address Book



Appendix A: SBook’s Menus and Menu Commands

 and

ing
ting”

ing
se is

ons,

lly
ding

s

The Format menu

SBook’s Format menu allows you to change the font and formatting of text, insert
remove icons, and change the page layout:

• The Font menu works as its counterparts do in other NeXT applications, allow
you to modify, copy, and paste fonts.  Its use is described in “Font and format
in Chapter 2.

• The Text menu works as its counterparts do in other NeXT applications, allow
you to change the formatting of text, and view and change rulers.  Its u
described in “Font and formatting” in Chapter 2.

• The Icons menu has several commands that allow you to insert and remove ic
as well as parse entries:

The Insert telephone icon command, the Insert email icon command, and the
Insert envelope icon command allow you to insert icons by hand (SBook usua
inserts icons automatically).  The use of these commands is described in “Ad
icons” in Chapter 2.

The Parse entry command (command-P) parses the selected entry.  It i
described in “Reparsing” in Chapter 2.

The Remove all icons command (command-R) removes all of the icons from the
selected entry.  It is described in “Removing icons” in Chapter 2.
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The Tools menu

SBook’s Tools menu allows you to print reports and use several helpful tools:

• The Inspector... command brings up the Inspector panel.  This panel and its
is described in “SBook’s Inspector Panel” in Chapter 2.

• The Colors... command brings up a standard Colors panel.  The use of this p
is described in “The Colors panel” in Chapter 2.

• The Logging panel... command brings up the Logging panel.  This panel
described in Chapter 6, Logging what you do with SBook.

• The Envelope panel... command brings up a blank envelope print panel so t
you can fill in an address and mail an envelope.

• The Unlock modem command (command-U) unlocks the modem.  This is
described in “Dialing with your modem” in Chapter 3.

• The Reports menu allows you to make three kinds of reports: address bo
mailing labels, and bulk email mailings.  These three reports are describe
Chapter 5, Making Reports with SBook.

• The Entry actions menu allows you to use keyboard equivalents to dial the pho
print envelopes, and send email:

The Dial first phone in entry command (command-d) dials the first telephone
number in the entry, just as though you had clicked on the icon.  Dialing a 
phone number is described in“Dialing the phone” in Chapter 1.

The Print first envelope in entry command (command-e) prints the first address
in the entry on an envelope, just as though you had clicked on the icon.  Pri
an envelope is described in“Printing envelopes” in Chapter 1.

The Send first email in entry command (command-E) opens a Send window
addressed to the first email address in the entry, just as though you had click
the icon.  Sending email is described in“Sending email” in Chapter 1.
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The Preferences panel
SBook’s Preferences Panel allows you to view and change SBook’s six different typ
preference settings: General settings, settings concerning Envelopes, settings determining
which files are opened at Launch time, settings concerning Logging to a file or email,
settings for SBook’s Dialing Rules, and settings for SBook’s Dialing Method.

• SBook’s General, Envelopes, and Launch settings are covered in this section.

• SBook’s Logging settings are covered in Chapter 6, Logging what you do with
SBook.

• SBook’s Dialing Rules and Dialing Method settings are covered in Chapter 3
Dialing the Phone with SBook.

You can bring up the Preferences panel at any time by choosing Info>Preferences.  The
pop-up menu at the top of the panel allows you to choose between the six diff
subviews corresponding to the six different types of preference settings:

The General subview

The General subview controls several miscellaneous settings: autosave, autom
backups, and display of entries. In addition, using the General subview, you can reset all
of SBook’s preferences back to the factory defaults.  

If you want to reset all of SBook’s settings, click on the large button labeled Restore
Factory Settings near the bottom of the panel.

pop-up menu
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Once you click on the Restore Factory Settings button, SBook will display an alert panel

Clicking on Remove all defaults changes all of SBook’s preferences back to the factor
settings, so you should be really sure you want to do this.  If you are sure, and you cl
Remove all defaults, SBook will display another alert panel:

This panel informs you that the factory defaults cannot be restored until you quit S
and start it up again.  If you want to start using the factory defaults right away, and you
no more work to do or files to save, click on Yes.  Otherwise, click on No and finish your
work before leaving SBook.

The General subview also allows you to set the following preferences:

• The checkbox labeled Autosave after... determines whether autosaving is turne
on, and if so, how many minutes of inactivity pass before SBook autosaves.

• The checkbox labeled Keep backup files determines whether SBook keeps aut
matic backups.

• The field labeled Maximum entries displayed at once determines how many
entries SBook will display (in the display window) at once.  When you attemp
display more than this, SBook only displays the number of entries selected.
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The Envelopes subview

The Envelopes subview controls envelope printing:

The box labeled envelope font allows you to view and change the default font for addres
printed on envelopes:

• The field labeled first line  determines the font that the name is printed in

• The field labeled others controls the font that all subsequent lines are printed i

You can change either one of these two font defaults by clicking on one of the bu
labeled set.  The Font Panel will appear so that you can choose and set the font.

The box labeled envelope stationery allows you to change the default directory and fi
containing the default return address:

• The field labeled directory  determines the directory which contains all the defa
return addresses that appear on the default return address pop-up on the en
panel (see “Printing envelopes” in Chapter 1):

• The field labeled file determines which file in the above directory is the defaul

You can change these fields by clicking on the button labeled set default file.

If the checkbox labeled Print addresses in ALL CAPS is checked, SBook will print all
return addresses in all caps, regardless of how they appear in the SBook document 

return address pop-up
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The Launch subview

The Launch subview controls which files are opened automatically each time you lau
SBook.  In the scrollable field labeled Files to open on launch: there is a list of all the files
marked to be opened on launch. (By default, no files are marked to be opened on la

Clicking on the button labeled Add brings up a panel that is just like a standard Open pa
except that it is named Add autolaunch file:

Choose a file in the usual way, and click on OK .  Once the file is added, you will immedi
ately see it appear in the Files to open on launch: field.

You can delete a file from the Files to open on launch: field by selecting the file in the
field, then clicking on the button labeled Remove.  You will be presented with an aler
panel in which you will need to confirm whether you really want to remove the file fr
the field.  Clicking Yes (the default) will remove the file.

At the bottom of the Launch subview, the checkbox labeled Hide on autolaunch deter-
mines whether SBook hides itself when it is automatically launched from your doc
otherwise.  By default, this button is checked.
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Appendix B: Installing and Licensing SBook

Installing SBook
The SBook distribution disk contains the SBook application itself, a help file ca
“Instructions.sbook”, and a folder called “DemoFiles” containing the three demo f
“developers.sbook,” “congress.sbook,” and “recipes.sbook”:

Copy SBook from the distribution disk to “/LocalApps,” if this copy of SBook is to be us
by all users of your machine, or to “~/Apps,” if this copy of SBook is only to be used
you, and you prefer to keep it in your home directory.  You may want to put SBook on
dock, if you plan to use it often.

Copy Information.sbook to “/LocalLibrary,” if you have put SBook in “/LocalApps,” or 
“~/Library.”

If you want to play with the demo files that are included in the distribution (the files “de
opers.sbook,” “congress.sbook,” and “recipes.sbook”), copy them to a convenient pla
your home directory.  Or, if several people on your system are going to be interes
these files, you might want to put them somewhere public.
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Registering this copy of SBook

When you start up SBook for the first time, you will see a warning panel:  

Click on the button labeled OK , or press return.  A large panel labeled Registration Panel
will appear on the screen:

You will need to type your license string in the box provided on the Registration Pan

• If you have purchased a regular single-user license or a site license, you wil
your license string clearly marked on your license card (the bright-colored printed
sheet of paper that was slipped into the front of your manual).

• If you have purchased a student license, you will have received your license s
directly from us, by email, US Mail, or fax.
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SBook automatically determines from the license string whether this is a single-us
network license.  If it is a network license, SBook also determines how many simultan
users this license authorizes.  You don’t need to enter any of this information — just 
the license string.

Below the license string, if this is a single user license, enter your name.  If this is a ne
license, enter your company's name.  Then click on Register Program.

If you have mistyped your license string, a panel will appear to inform you that the s
you entered was not valid.  Click OK .  You will be returned to the Registration Panel s
that you can try again.

When you have entered a valid license, you will see one of two alert panels, depend
whether the license string that you entered was purchased for a single user or for a ne

Successfully registering a single-user license causes the license information to be w
into your defaults database.  The application itself is not changed.  This allows you t
the application freely, but prevents other people from using it unless they have
obtained a license number from us.  You can move or copy the application and still 
freely as long as you retain the licensing information in your defaults database.

successfully licensed for a single user

for a network
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Successfully registering a network license, on the other hand, causes the installed c
the application to be modified so that anyone may use it, up to the number of simulta
users allowed by the license.  This modification is called branding, which is why the panel
announces that the application was “branded successfully.”  If a branded copy of SB
moved or copied, it will cease to be branded, and you will need to re-brand it with the
inal license number.  

You have now installed and licensed this copy of SBook.  The rest of this chapter des
SBook licenses and license agreements in detail.  You may want to read it now, or
back to it later for reference.  If you need basic information on how to start using SB
read Chapter 1, Getting Started with SBook now.

SBook Licenses

The License Panel

When you are using a copy of SBook, you can see who this copy of SBook is licens
by looking at the License panel.  Choose Info>License... to bring up the panel.  (If the copy
is not licensed, you will get the Registration panel instead.  See Page 74 of this chap

If this copy is licensed for a single user, the name of the person will appear.  If it is lice
for a network, the name of the company will appear, along with the number of simultan
users this license allows.

single-user license panel

network license panel
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Besides the name of the person who licensed the application, the License panel displays the
customer number of the person who bought the license.  This allows us to track cop
our software.

Knowing your customer number does not make it possible for unauthorized individua
determine your license string and use it to license software.  Your license string will never
be displayed.  Nobody can learn your license string unless you release it to them.

Single user licenses

Successfully registering a single-user license causes the license information to be w
into your defaults database.  The application itself is not changed.  You can move or
the application and still use it freely as long as you retain the licensing information in
defaults database.

Your single-user license allows you to run SBook on only one computer at a time. 
cannot run more than one instance of SBook, even if it is on the same computer.  
users on the same machine or network will be able to start up the program, but it will 
as a demo version unless they have also obtained a license number from us.

Your license agreement allows you to make copies of SBook directly from your dist
tion disk, and give away as many copies as you like.  You are not allowed to distribute your
license string.  The copies that you distribute will work as demo copies.

Network licenses

Successfully registering a network license causes the installed copy of the application
modified so that anyone may use it, up to the number of simultaneous users allowed 
license.  This modification is called branding, which is why the panel announces that th
application was “branded successfully.”

+ Licensed single users can use a branded copy of SBook without affecting
many other users can use it at once.

If a branded copy of SBook is moved or copied, it will cease to be branded, and you
need to re-brand it with the original license number.  To rebrand a copy of SBook, you
have write access to the file.  When you start up the copy, it will behave as though 
never been licensed, and you will have to go through the licensing process as descri
Page 74 of this chapter.

Every site with a network license should have a designated contact person who is re
sible for licensing and maintaining SBook.  Only the contact person needs to know

customer number
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license string, since it is only needed when the copy is initially branded or re-bra
because it has been moved.  The license string should not be distributed among the use.

Your license agreement allows you to make copies of SBook directly from your dist
tion disk, and give away as many copies as you like, as long as you do not brand them
your license string or modify them in any other way.  You are not allowed to distribute you
license string.  The copies that you distribute will work as demo copies.

If your needs change, and you want to add more users to your license, you can alway
a new license number by telephone or fax and add the additional users right away.

Requesting source code

You can request a copy of SBook's source code, free of charge, at the time you bu
software, or at any time thereafter, for as long as you remain a licensed user.  If you r
source code after you buy your software, there will be a nominal handling fee; conta
for more details.

In order to request source code, you must first sign a special source code release agreem
and send it back to us by fax, or US Mail.

You will receive a complete copy of the source code, except for three files, which
supplied to you as object files: “parse_case.o,” “parse_address.o,” and “parse_compa
These files contain the heart of SBook's parser.  We don’t provide code for these
because they are compiled with tools that are not widely available.

Once you receive your source code, you are free to modify the code and make add
then recompile it to make copies of SBook for your own use.  However, neither the original
source code, nor any recompiled copies of it, may be distributed to anyone.

For more information about ordering source code or the specific terms of your source
agreement, contact us.
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